1 (edited by lme 2017-11-03 09:58:49)

Topic: ethernet connection keeps connecting and disconnecting

Hello everyone!

I am quite new to linux distros and absolute linux in particular, so bear with me if i ask "stupid questions" for i am indeed a newbie. Here it comes:

Yesterday i set up Absolute linux on an old SAMSUNG netbook (model NP-N130, specs here: http://www.samsung.com/us/computer/pcs/ … 04US-specs), using rufus 2.17 to create a bootable usb from the absolute-14.2.iso. Choosing the "default guided installation" it worked quite well and installed without problems.

I ran into my first issue, when i plugged my ethernet cable in: The network centre cycles as follows:
~1s: trying to connect
~0.5s: connected
~1s: disconnected

During the 0.5 seconds i am indeed able to load websites (tried it with the google.com frontpage under the preinstalled firefox).

I am running into a similar problem trying to connect to my wi-fi. It connects for a really short period before it disconnects automatically and stays disconnected until i prompt it to connect again.

From my perspective, the fault should lie with either the distro-intrinsic networking protocols, missing drivers for the notebooks network-card or my router.

Does someone have an idea how i can check and fix this connectivity problem?

If you need additional information provided, just tell me the needed console-commands (as i said, i am pretty new to this and linux in general).

Kind regards and thanks in advance,

P.S.: oh, and i accidentally installed a qwerty-us-keymapping. Is there any console command that switches it to qwertz-germany mapping? I tried some digging in the forums and wiki for slackware, but the commands i found don't quite do the trick, especially when i try to permanently change it for all users, not just one-session-one-user. It is more of a minor annoyance at this point, but help would be appreciated smile

2 (edited by shevy 2018-01-13 06:45:00)

Re: ethernet connection keeps connecting and disconnecting

Hello Ludwig,

I also had the same problem as you had. I do not how or why but dhcpcd was running already (I could connect via shaky internet connection as well).

I tried to kill it by the PID via k9 - and then I got the surprising message that the no program was running via dhcpcd.

I looked at "ps ax" or "ps aux", I forgot, and ... it was running, but at another PID.

I think that there is some script that constantly tries to respawn dhcpd. Running dhcpcd manually
also led to some kind of conflict. This was surprising to me because normally dhcpcd "just works"
without problem.

I then recompiled dhcpcd after I removed the default one at /sbin/ (via rm; I have all programs
archived locally too). This is not the recommended way, to just remove it - it just was brute
force. :-)

Afterwards I could use my self-compiled dhcpcd (at another prefix location though) just fine
without problem and my internet connection is stable. I guess there is some script with
a hardcoded path wired to /sbin/ and it detects some problem that leads to some infinite
respawn cycle, so my idea was to just disrupt this cycle, without even knowing which
script is responsible).

I am not sure if this helps in your case but I wanted to mention it; I write this rom absolute,
already compiled mate-desktop + xfce from source (using mate-terminal as main terminal
right now). Next steps for me will be the KDE stack; qt-5.10.0 I have already compiled.
(I use a set of ruby scripts to help me compile everything, but the quality of these scripts
is not great ... it's more hackish, but it works for me case).

I guess the faulty dhcdp-related script will eventually be fixed.

As for the keyboard, I use a german variant without deadkeys so I can relate to your problem.

I usually use:

  setxkbmap -model pc105 -layout de -variant nodeadkeys -v 10

I think th ere is some file where you can put it... a xorg file or something. I do not remember offhand
... perhaps xinit works? Or some other file. I usually just call an alias when I am in xorg (I
usually use fluxbox; there is some file called init for fluxbox where commands can be put;
I also use xfce and mate-desktop when I need a bit more of a GUI; KDE I only use kde konsole
really, not the rest ... big_smile).

Awesome distributions: slackware-family, GoboLinux, VoidLinux and in general all systemd-free variants

Re: ethernet connection keeps connecting and disconnecting

I have to say that its a Slackware based thing because Zenwalk and Vector do the same thing... I've never been able to resolve it on my machines so unfortunately I cannot use Absolute anymore as I find internet connectivity is a vital part of computing nowadays....

I'll keep watching this thread in the hopes that the developer could help in some way..?

Re: ethernet connection keeps connecting and disconnecting

> I have to say that its a Slackware based thing because Zenwalk and Vector do the same thing.

Perhaps there are some scripts shared, I do not know. But I can also tell you that I do not
have the same problem on slackware. There, I can use dhcpcd just fine without it being
constantly respawned, so I think that it is something that has more to do with absolute
linux than slackware itself or perhaps the kernel.

I am sure psherman will eventually get to find out which is the faulty part. For me things work
here very fine after having compiled dhcpcd.

Awesome distributions: slackware-family, GoboLinux, VoidLinux and in general all systemd-free variants

Re: ethernet connection keeps connecting and disconnecting

Hello!  A noob here. 

I'm having the same issue.  I turned off auto-connect after I had a connection, but it didn't make any difference.  I don't know enough to do anything more at this point.  I am testing a bunch of distros on a laptop (that Windows 10 updates "broke") to learn and to see which one(s) I like.  Anyway, so far I have 7 distros installed.  Distros are based on Arch, Ubuntu, Slack, and Debian.  Only Absolute is having this problem.  The other Slackware based distro I have is Puppy Slacko and it is connecting just fine.

Re: ethernet connection keeps connecting and disconnecting

Hey BigG!

Granted the particular kernel Absolute uses is in question, you should be able to compare any other functioning OS where you have a stable connection with against Absolute by checking "keepalive" values.

PS - Absolute's Slackware based, not Slacko. It only draws upon their repos. Neither run Systemd.

PSS - If you get a chance, try Peppermint (Systemd). Pretty quick for a Ubuntu build.

7 (edited by BigG 2018-02-02 01:56:37)

Re: ethernet connection keeps connecting and disconnecting

Thanks for the response Speedster.  I did not say that Absolute was Slacko or anything else.  I listed the different bases of the Linux versions I have installed and abbreviated Slackware as simply Slack.  During a previous foray into Linux in the mid 1990s, it was common to refer to Slackware as simply Slack.  Sorry if that is not appropriate now days.

It took a while to figure out what the "keepalive" values are and how to check them.  As noted before, I'm a noob.  But I did finally track down how to check them.  The Absolute installation tcp_keepalive_time, _intvl, and _probes, are 7200, 75, and 9 respectively, which seem to be normal from what I can determine and is what Linux Lite is using on the same laptop.

I also figured out how to check the drivers for the wifi card.  Both Absolute and Linux Lite (which is working just fine) have the same driver module (r8169 for the Realtec card).  The Absolute driver is actually newer (4.14.12) than the LL driver (4.4.0-93).  I have no idea how to replace a newer driver with an older one to see if that helps, especially with the wifi not working.

One thing I noticed is that Absolute identifies the wifi card as wlan0 while all the other distros (as far as I have checked so far) identify it as wlp2s0.  I don't know if that would be an issue or not.

I may try to manually set up the wifi.  I did it for my Arch installation, so I guess I can do it for Absolute.

Re: ethernet connection keeps connecting and disconnecting

Well, after several hours of trying to manually connect, I can't get it to work in Absolute.  Maybe I'll download another .iso later to see if this has been fixed (indy452 noted that it may be a Slackware issue), but for now, I'll remove this distro to make room for something else to try.

Re: ethernet connection keeps connecting and disconnecting

It probably has something to do with the newer driver...IDK.  In older versions I never had the connect/disconnect issue like now..  Its too bad actually because Absolute was my favorite long term distro, still would be but I can't connect and I don't care to fiddle faddle around changing stuff I don't understand.  Any more for me, if it doesn't work out of the box I ditch it and use something that does.   I just hang around waiting for a fix so i can re-install Absolute again someday when this ethernet thing gets fixed... Hopefully, it gets fixed with this new up coming release..

Re: ethernet connection keeps connecting and disconnecting

BigG, noob here too, sort of. wink

Card naming conventions usually only matter when dealing with GUI apps, so no biggie here. As for building some other version of the driver, let's see if we can side-step that for the moment. I'd like you to read through this article taking into account the time it takes for YOUR connection to break. While you can play around with values, note you're going to have to append those echos`and their confirming sysctl -p refresh into your rc.local prior to rebooting, then they should stick. If Absolute's still installed, maybe this is enough.

As for you Indy452, do you know the [vendor:device] of your card?

Do you run Puppy?

Re: ethernet connection keeps connecting and disconnecting

Thanks again, Speedster.  The time to disconnect is maybe 2 seconds at most.  The entire connect, disconnect, start over cycle is about 3 seconds.  Meanwhile, there is enough connection to my access point that wpa_cli can get a full scan report from the device.

Even if reducing the keepalive value to 1 second did work, wouldn't that 1) still indicate a deeper problem and 2) be a huge waste of cpu cycles with the constant refreshing (I'm assuming that is what keepalive is doing)?

I do have Puppy Slacko 6.3.0 as a full installation.  The keepalive values are the standard 7200, 75, and 9.  It, too, identifies the wifi interface as wlan0 and works just fine with those values.  System information for Puppy shows that it is using rtl8192ce , too, but it uses an even earlier version (4.1.11) than Linux Lite.

So I guess now I need to figure out how to replace the newer driver with an older one in a distro without an internet connection.

Re: ethernet connection keeps connecting and disconnecting


Driver building requires the gcc compiler, probably already onboard, the kernel source, headers and your driver package. I can't answer for you, but, is Absolute enough of a contender to invest the time it takes to put this all together? It still might not work you know, but you will certainly have gotten your footsies wet.

As for getting what you need without a connection, well, you can grab most of what you need with any of the other distros that connect. What I don't know is which exact version you're running?

BTW, install didn't take long, did it?

Consider, Absolute-15 Beta3 released - New kernel!

Re: ethernet connection keeps connecting and disconnecting

No, it is not worth the effort and since I'm not even comfortable with shell commands yet, digging that deep would be putting the wagon before the horse, so to speak.

As to the time to install, it did not take all that long, but I have to add the time setting up grub (2 not legacy) to recognize Absolute, so lot's of rebooting on a fairly slow machine.

Soooo, moving on to the next distro.  I think I'll move away from Slackware, too.

Thanks for the help!