1 (edited by FrenchCA 2018-01-13 10:39:53)

Topic: Control Panel *Langue* doesn't work on Absolute Beta 15

Hi,


Localization language (control panel) doesn't work.


Selecting the language, keypad, applying changes and restarting.
After rebooting the system remains on the default layout.

When you look at the packages, you can see that all language packages are installed.

Other observation

First test summary of the beta 15.0 version.

All installation steps with automatic partition configuration work fine.

Excellent choice of software. The desktop environment is very reactive. Adding a user works well. The control panel is complete and very easy to use. Excellent work.

regard

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

There is the same issue on beta3.
I didn't use the control panel option but edited the /etc/profile.d/lang.sh manually.
After rebooting no localization nowhere except smplayer and calibre in which the display language was changed.
I could write non-English on scite but not on xterm.
On xterm there was the warning
GTK WARNING ** :locale not supported by C library
which i understand as a glibc-i18n problem.
I removed the glib* and the kenrel entry from the excluded list from gslapt
and updated them.
SOLVED.
glibc-i18n was version 2.26-x86_64 and updated to 2.27-x86_64

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

Hi,

Thank you for your information.
I will test this on new Absolute beta4.

I'll be back to give you some news if it work.

best regard

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

New install Absolute15 Beta4

I modified the file /etc/profile.d/lang.sh manually.  I replaced us_US by fr_CA but it doesn't work. change also in lang.csh

Nothing work for locale language and keyboard layout

Can you put here the modifications you made to the lang.sh file.

The current version of glibc-i18n is 2.27-x86_64

After the installation the update was done correctly. The multimedia codec installation works perfectly. Changing the screen resolution works correctly. Sound management too. All seen to work but the big problem I can see is localization. Well is not only on Absolute Linux. All Slackware derivate has this problem. It's not easy to just put our localization.
I think that's the Slackware problem of all time. The difficulty to simply install in our language. This is probably the reason why Slackware is less popular in the world.

This section in control panel need to work and attention by developer

thank

5 (edited by kestes 2018-03-19 12:44:39)

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

Here is my /etc/profile.d/lang.sh file

 LANG=el_GR.UTF-8
  LANGUAGE=el_GR.UTF-8
  LC_TYPE=el_GR.UTF-8
  LC_MONETARY=el_GR.UTF-8
  LC_NUMERIC=el_GR.UTF-8
  LC_PAPER=el_GR.UTF-8
export LANG=el_GR.UTF-8
export LC_COLLATE=C 

Once you edit this file relogin is needed.

For the keyboard layout change
i 've added this line in my $HOME/.xinitrc file

setxkbmap -option grp:switch,grp:alt_shift_toggle us,el 

and copied /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf to /etc/X11/xorg.conf.d
then edited /etc/X11/xorg.conf.d/90-keyboard-layout.conf

Here is my /etc/X11/xorg.conf.d/90-keyboard-layout.conf file

Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbLayout" "us,el"
        Option "XkbVariant" ",extended"
        #Option "XkbOptions" "terminate:ctrl_alt_bksp"
        Option "XkbOptions" "grp:alt_shift_toggle"
EndSection

I use alt+shift to change the keyboard layout when i need to.

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

Big Thank !

I tried these solution but doesn't work for me...   

The best way to solve this important problem for AbsoluteLinux is through by the developer.  I wonder if it's not a file permission issue.

When we make the change with control panel (languages) maybe the folders and files do not have the necessary permissions to make the change.

it's work in progress

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

On a slackware test virtual machine i changed the /etc/profile.d/lang.sh setting
to fr_CA.UTF-8 and relogin.
Here is the result screenshot

https://www.dropbox.com/s/x2bid33zgul47 … .jpeg?dl=0

Re: Control Panel *Langue* doesn't work on Absolute Beta 15

Great !

Probably I make a bad action in x11 file. The system is broken and can't boot the gdm. Need to reinstall and I will trie another time this weekend.

big thank