1 (edited by kestes 2018-03-08 17:05:18)

Topic: [SOLVED]Latest lilo doesn't support UUID

I have installed two OSes on separate disks on my desktop.
One has Slackware 14.2 (32b) and the other one Absolute beta3 (64b).
When i installed Absolute Slackware's disk was not connected so Absolute's installer saw only one disk
(for that moment sda).
After finishing the installation i connected the disk with Slackware on it (now Slackware is sda and Absolute is sdb)
I then edited the file /etc/fstab on Slackware changing the root= /dev/sda line to root = "UUIDXXX..." and ran the lilo -C /etc/lilo.conf command.
Slackware booted fine.
The same action on absolute gives a kernel panic.
Slackware's lilo accepts and adds absolute as a second option on boot screen after i added
this lines in /etc/lilo.conf file
linux=vmlinuz
root = "UUID=xxxxxx........"
read only
Absolute's lilo Adds only Absolute

2 (edited by kestes 2018-03-07 20:50:28)

Re: [SOLVED]Latest lilo doesn't support UUID

I have changed the root line form
root = "UUID=xxx..."   
to
root = /dev/sdb1
Run lilo -C /etc/lilo.conf
slackware added
Now in /etc/lilo.conf i have

image = /boot/vmlinuz
  root = /dev/sda5
##  root = "UUID=69cfc568-42b2-4dd4-a7d6-1f2a3b94967e"
  label = "Absolute15Beta3"
  read-only
##
image = /boot/vmlinuz
  root = /dev/sdb1
#  root = "UUID=e737a623-44e8-43f5-82ae-fd65373af3ab"
  label = "Slackware14.2"
  initrd = /boot/initrd.gz
  read-only

but when i select the slackware 14.2 from the boot menu
it boots Absolute
help

Re: [SOLVED]Latest lilo doesn't support UUID

I didn't know that this is a common issue on distributions that use lilo.
A search on the internet learned me that lilo can't read partitions other than the / partition or the partition that is bootable and contains
the boot code.
With that as a fact i have two options to add absolute to the slackware's boot menu
copy the contents of absolutes /boot folder to slackware's /boot folder
or install lilo on the partition where absolute is installed and point lilo to that partition with the option table = /dev/sda
I choose to make a folder into the slakware's /boot folder and copy there everything from absolutes /boot folder.