Topic: updating the menu

I have now installed a few items. Firefox showed up in the menu but other things did not ie Chromium and Thunderbird. How do I get these in the menu please.

Re: updating the menu

The IceWM window manager in AbsolutLinux is lightweight and fairly easy to tweak, but the downside is that many packages (outside AL's own) do not include necessary menu bits. You'll have to fix this manually.

The first step is to check that you have a file for starting the program in your /usr/bin/ (or /usr/local/bin/ ) folder. Open a terminal, write "thunderbird" (without the quote marks) and hit "enter". Does the program start? If so, well and good. If not, create a symlink. In the terminal (as root), write
ln -s /usr/lib/thunderbird/thunderbird /usr/bin/

That is, if the program has been installed in the folder /usr/lib/ . For me, this is where I find Thunderbird. Other programs might be found in /usr/share/ or somewhere else, it depends on how the package was configured.

Next step is to edit your /home/<username>/.icewm/menu file. Note that the file is placed in the hidden .icewm folder - it won't show up in the SpaceFM file manager unless you set it to show hidden files (you can toggle this with Ctrl+H).
Look for the appropriate section (e.g. Internet Apps, line 38 or thereabouts). Add the following new line among the others starting with "prog":
    prog "Thunderbird" "thunderbird" thunderbird
Save and exit.
First "Thunderbird" (with quote marks" creates the text label in the start menu. Second ("thunderbird") specifies the icon and the third is the start command. The icon is fetched from /usr/share/icewm/icons, so you must put an icon file there! You'll find the Thunderbird icons in /usr/lib/thunderbird/chrome/icons/default/

Now copy with a terminal command (as root):
cp /usr/lib/thunderbird/chrome/icons/default/default32.png /usr/share/icewm/icons/thunderbird.png

And the same procedure for Chromium...

There might be other (easier) ways to do this, my knowledge of Linux is fairly superficial. But it works. And it's easy to choose program names or icons freely after your own liking.
You can add, remove and edit the quicklaunch buttons on the toolbar in the same way by editing the file /home/<username>/.icewm/toolbar

Re: updating the menu

Many thanks khammer for your excellent reply. Its good that you explained what the commands were for not just what they are. Tried with Thunderbird and got that sorted. It shows and launches from the menu. So then I thought I'd do chromium. That doesn't launch when I type chromium in terminal so I typed
ln -s /usr/lib/chromium/chromium /usr/bin/
and I'm told it fails as the file already exsists.
Libre office also does not launch when type libreoffice in terminal so again I type ln -s /usr/lib/libreoffice/libreoffice/usr/bin/ but am told the file does not exist but I can see it in usr/lib.
Help please.

Re: updating the menu

Hi davidp,

it's odd that chromium doesn't start from the terminal. I installed the package chromium 49.0.2623.112-i486-1alien and it worked fine, I was also able to create a menu entry. Do you get any error messages when entering "chromium" (without the quote marks) in the terminal? It could be that some important file/program is missing and must be installed.

The Opera browser might be another alternative. It's less resource-demanding than firefox and uses the same pepperflash plugin as chrome and chromium. There are, as far as I know, no ready-made slackware packages, but it's fairly easy to install:
download the file … 5_i386.rpm

Find the downloaded file (e.g. /home/<yourusername>/downloads/opera-stable_36.0.2130.65_i386.rpm) If that's the proper place, enter the following in the terminal:

rpm2tgz /home/<yourusername>/downloads/opera-stable_36.0.2130.65_i386.rpm

This will convert the rpm package to a tgz package.

Now run (as root):

installpkg /home/<yourusername>/downloads/opera-stable_36.0.2130.65_i386.tgz

After installing, try to start from a terminal with the command opera. If it works, you can edit your /.icewm/menu file so that you get an entry in the start menu. If you get the message that the file doesn't exist, create a symlink as described earlier. Opera probably installed in /usr/lib/opera/ so check that folder for the executable file opera.

I don't use Libreoffice myself - I've used Openoffice for over 10 years and find it a little bit more stable plus that it launches a little bit faster. But again I find it odd that it doesn't start from a terminal. If the file /usr/bin/libreoffice exists, you should be able to launch it by simply writing "libreoffice" (without the quote marks) in the terminal and hit "enter". Again, does this give any error messages?

5 (edited by davidp 2016-04-19 16:08:07)

Re: updating the menu

I cant do anything at the moment as I have work to get done but just wanted to thank you for the reply. I think there is an error message when I try to launch chromium and there definitely is with libre office.. I'll check it out soon as I get a minute, and I'll look to installing Opera.

Re: updating the menu

Well, an error message should tell whether some necessary file/package/program is missing and hopefully it's something that's easy to find.
Query - have you installed all upgrades from AbsoluteLinux that are of a later date than the full iso file? If not, it could be worth doing. Remove the new sources you added to Gslapt so that only remains. Click Update and then View - Upgradeable. Install the new versions. Maybe this will solve some or all of the problems.

7 (edited by davidp 2016-04-24 13:44:19)

Re: updating the menu

I had to change out the hdd in this laptop as it was borrowed from another so I now have a fresh install on a different hard drive. I have fully update and installed firefox having adding the repo but firefox is rather slow so I followed your guide and downloaded and installed opera. All went well other than a few typos but opera folder does show in usr/lib. When I type opera in terminal nothing happens so I tried to create a system link and this is what I get

'failed to create symbolic link 'usr/lib/opera'  :File exists'

Do you have any suggestions please.

8 (edited by khammer 2016-04-26 16:29:29)

Re: updating the menu

What if you try starting by writing
In the terminal?
Remember that there must be a "slash" (/) at the beginning when you want to specify a path to a certain folder.
If that works, create a a terminal (as root) :

ln -s /usr lib/opera/opera /usr bin/

Then you should be able to start Opera by simply writing


In a terminal. And, of course, editing the menu so that you'll be able to start the program from there.

Re: updating the menu

I have checked and re checked the commands I am using and they are as you have instructed but not working.
/user/lib/opera/opera does not work either.

10 (edited by khammer 2016-05-02 10:36:11)

Re: updating the menu

Very odd...

You do have a folder named /usr/lib/opera  ??
And in that folder there's an executable file named opera ???

If so, the command /usr/lib/opera/opera should work... unless, of course, the permissions have'nt been set correctly for some reason. Correct permissions (allowing all users to start opera) should be -rwxr-xr-x
If not (if the last "x" is missing), you must change this. Easiest way is to run the following command from a terminal as root: chmod 755 /usr/lib/opera/opera